Trouble switching to Dvorak layout

Hi all,

I’m running into problems switching to a Dvorak layout by updating the firmware. I’ve followed all of the documentation that I can find, but after flashing, the keyboard is still in Qwerty.

I first tried to update the layout by running Chrysalis, so I don’t know if anything that it did when it first added its support could be affecting things.

I also tried adding #undef PRIMARY_LAYOUT_QWERTY just to be sure that it wasn’t defined somewhere else.

Any thoughts? Right now, I’m typing using the OS mapping and there are some keys that are very hard to get to.

I was finally able to figure out how to change the layout using Chrysalis. https://github.com/keyboardio/Chrysalis/issues/425

I’m still curious about why flashing from the command line and from the Arduino IDE did not affect the layout.

Probably because the first time your run Chrysalis, it will copy the current keymap into EEPROM, and set things up so that the keyboard looks at EEPROM instead of what is built into the firmware. This is done to make it easier to configure things with Chrysalis out of the box.

To use the built-in keymaps, you can go to “Keyboard settings”, and disable the “Use custom layers only” setting. If you want to start from scratch, you can also roll down the “Advanced” settings there, and reset the EEPROM to factory defaults.

Aha! That makes sense. It’s nice to hear that I’m not crazy. :slight_smile:

I think it would be great to mention this in the Wiki (troubleshooting maybe?). Would’ve saved me a lot of pondering why nothing works…

1 Like