Difficulty getting Keyboardio 100 into Dvorak mode

I am having trouble getting my new Keyboardio 100 to type in Dvorak mode. It tells me its layout is Dvorak, but it types as if it were the QWERTY I switched it from.

Somehow I imagined that switching layouts would be as simple as it has always been on my Kinesis Advantage and that I would not have to have any digital sophistication to get it to work. I’ve followed (many times over) the rather spare instructions at Model 100 firmware update to fix corruption issues. Clearly I am missing a step that would be obvious to others, but what it is I have no idea.

Did you use the “Keyboard layout” option in “Preferences”?

That tells Chrysalis which layout you use on your computer. As in, what layout your operating system is set to. If your computer is set to use QWERTY, changing this to Dvorak will not do anything, as it changes nothing on the keyboard.

To type Dvorak on the Model 100 while your computer is set to QWERTY, you need to change the keymap accordingly. The easiest way to do that is to go to the layout editor, and click the “Backup & Restore” button at the bottom of the overview area of the sidebar:

Screenshot from 2022-10-06 02-04-43

That opens up a dialog like this:

If you click on the Dvorak label in the Library, then click the Import button, Chrysalis will import the layout. You can then save that to the keyboard, and it’s in Dvorak mode.

It’s not the most discoverable thing, we’re working on improving it, but it will take a little time 'till we have something easier and more straightforward.

Thank you, @algernon! That solved my problem. I am very grateful.