Chrysalis 13 not updating and no connection to keyboard with new (May 2023) firmware

I just updated the firmware from the October version to the newest (highly suggested) firmware from 5th of May. This was done via Chrysalis 12.0 and worked fine.
After the keyboard restarts and I wanted to connect the keyboard with Chrysalis 12 again I get an error: “Communication timeout”.

C. 12 did also try to update to version 13, but stops with an error message:

Error during update: Error: New version 0.13.0 is not signed by the application owner: publisherNames:, raw info: { “SignerCertificate”: null, “TimeStamperCertificate”: null, “Status”: 1, “StatusMessage”: “The form specified for the subject is not one supported or known by the specified trust provider” }

Therefore I downloaded the Windows installer of C. 13 from the website. When I try to install C 13 this works (or seems to work), but when starting C 13 I get the error message:

Chrysalis has detected that it is running in an unsupported environment, such as with an Electron version other than the one supported upstream. If you are using Chrysalis through a distribution’s package repository, please consider using the official builds instead.

I then downloaded the zipped version of C13, but after unzipping and starting C13 I get the same error message.

I tried to deconnect and reconnect the keyboard and to connect it with C12 again, but still the same “Timeout” error message.


The keyboard seems to work, although I am now using a standard keyboard to type this message.

C13.1 pre-release produces the same error message and also tells me I should download the official release. Not funny, when this is exactly what you did…

Version 13.2 opens without an error message (from the unzipped package), but I still get a Connection Timeout error when trying to connect to the keyboard.

I got response (PM) from the support how to connect the keyboard again, which worked finally:

Hold in the ‘Prog’ key as you connect the keyboard. Prog will glow red. From there, open up Chrysalis and do a firmware update, making sure to select the “factory reset” option.

I was using the unzipped version of Chrysalis 13.2 for that.