Model 1 stops inputting when mac sleeps

I’ve seen the same behaviour on Linux, but put it down to a badly behaving vmware client. LED modifiers still light up, but no keys are sent to the host.

I can make it a trifecta. I had to move the mouse to wake up a PC yesterday, because it ignored shift and spacebar.

Interesting. That’s something I’d seen previously, but thought we’d resolved before we shipped the MP firmware. @pnunn, @dshields - Have you flashed new firmware onto your keyboard or are you still using the firmware we shipped?

Hi @jess, I’ve flashed the Dvorak layout and I assume the latest firmware from the repo. I set up as detailed in the instructions.

@pnunn - Got it. What version of the Arduino IDE are you running?

I’m still not convinced this is the keyboard so I’ve switched to an HTML based vmware client which avoids USB pass through. I’ve flashed new firmware, latest trunk I believe with arduino IDE1.8.5

Understood. It’s definitely something for me to keep an eye on.

Just for another data point, I have not had this problem on my Mac running 10.13.0.

I was experiencing a bit of weirdness, but flipping the USB cable sorted me out. I think I read somewhere else about someone getting a weird cable like that.

Thanks guys, Im going to try and use the keyboard all day today and see how it goes. The ‘A’ and space placements are already driving me nuts :wink:

That’s…a little weird. Please keep an eye on it.

1 Like

Ok, so having switched from the native vmware client, which may have USB pass through issues, to an HTML based client, my issues have gone.

Ok, so I’ve been using the keyboard all day today and apart from the layout driving me crazy :slight_smile: I’ve had no dropouts at all. It might have been the connector I guess as it was unplugged between uses, but, so far so good.

1 Like

Mine just started doing this, too. When the PC sleeps, the keyboard also sleeps, only it doesn’t restart when I wiggle the mouse to wake it up. I have to unplug and replug to force it to wake up and be recognized again.

I was actually talking to someone about that Windows issue being a possibility tonight. I believe it to be a different issue than the issue originally described on the Mac side.

I’m wondering if it may be a consequence of the fix for getting the LEDs to shut off when the host goes to sleep. I had pulled the latest of all the libraries a couple days ago when I last flashed the board.

I… Didn’t think I had taken that change. can you make sure to create a github issue on Kaleidoscope describing what you’re seeing?

Will do, in the morning. I may be totally wrong, most first guesses at debugging are. And I was basing the guess on discussions here, not on looking at commit logs.

1 Like

Starting with conjecture in a place where other people might be able to quickly chime in and steer you in the right direction is a perfectly valid triage technique.

3 Likes

Also having this issue. Is the accepted fix switching the USB cable?