Model 100 Error Updating Firmware

OS: MacOS 12.5.1
Chipset: Apple M1 Pro
Inside Chrysalis (installed using brew install --cask Chrysalis):

  1. Click Hamburger on top left
  2. Click Firmware Update
    • Under “Update firmware”, “Latest version 0.11.1” is selected
  3. Click “Update”
    • Popup “Are you sure you want to update the firmware?” comes up
    • has instructions to hold down top left corner of keyboard (PROG key) before clicking on Update. Instructions say to keep PROG key held down until keys start flashing green across the first column
  4. I click cancel first
  5. I hold down PROG key
  6. Click “Update”
  7. Click “Continue”
  8. First 2 steps complete
    • PROG key turns red (I am still holding down the PROG key)
  9. 3rd Step “Flashing” takes a long time and eventually “error while flashing firmware” warning pops up on the bottom left
    • PROG key is still red and i kept it held down from since before clicking on Update
    • first column of keys never flashed green

If i unplug the keyboard and plug it back in after this it is reset to default settings

If i leave it plugged, Chrysalis still recognises it but tells me i need to update firmware, but the same issue still persists and i eventually get the “error while flashing firmware” warning

I have the same problem under windows too.

Can you try the latest firmware snapshot on the Chrysalis download page? we do not maintain whatever is in homebrew.

Getting a similar problem here, locks up during second step (entering programming mode), PROG key eventually turns red and then sometimes the LED key turns green, but never goes farther than that. Tried both with the 0.11.1 firmware and the 0.90 snapshot, no dice (looks like it fails while trying to enter programming mode anyway, not at the flashing step).

Chrysalis 0.11.3, NixOS. Editing my layout works fine though.

Edit: I’ll try on a Windows device tonight to see if that helps

Update from Windows: worked perfectly fine, first try! Not sure what was wrong on NixOS as I’ve used that setup in the past to update a Model 01 firmware without any problem. Will keep investigating :slight_smile:

Perhaps the reason the flash fails on NixOS is due to permissions? As in, you may have permission to write to the serial port when the keyboard is in normal mode, but not when it’s in bootloader mode?

The developer console (ctrl+shift+i) should have more information about that, and the debug bundle too. If you end up reproducing the problem on Linux, I’d like to ask you to create a debug bundle (Report a Problem from the main menu, then Create Bundle, and once it is created, you can save it), and open an issue on GitHub with the bundle attached. That’ll give us a whole lot of information about what may have gone wrong.

1 Like

Here you go!

In the meantime I’ll plug my Model 01 in and check that flashing it still works; otherwise you may probably discard this as “strange NixOS setup” :smiley:

Seems like issue was fixed for me after updating to Chrysalis 0.11.3

Updating to 0.90 made the trick for me.

Yes, updating to Chrysalis 0.11.3 and flashing firmware 0.90 seems to have fixed it

I am also having this problem, but I had upgraded to Chrysalis 11.4 and flashed 0.90.1+42, and then my keyboard became unresponsive. I can un-plug and re-plug and flash it again, but the keyboard is only lighting up the LED key for a few seconds afterwards.

maybe you need to do the factory reset step here after flashing 0.90

i noticed it was a step in this post and did the factory reset after flashing 0.90
i wanted to be sure so i might have done it more than necessary, but in total i did 3 flashes

  1. flash 0.90
  2. factory reset
  3. flash 0.90 again

Also, i noticed that 0.11.4 of Chrysalis renders the #0 layer weirdly for me, it displays as a long string of numbers instead of just “#0”, so maybe you could try 0.11.3 instead if it still doesn’t work for you on 0.11.4

I’ve got 2 model 100s and i flashed one of them with 0.11.3 and then the next day at work after updating to 0.11.4 i flashed the other keyboard, both seem to be working fine, only that weird rendering bug on 0.11.4 seems to exist

To add a datum point, I could not update the firmware on Linux, but could using the Windows portable version.

Arch Linux, attempted with AUR packages chrysalis and chrysalis-bin version 0.11.4-1. Also tried the Appimage version 0.11.5.

Haven’t tried doing anything else with the Linux versions yet (only just got it, and need to learn how to use a 60% keyboard before messing with it too much).

It’s common to experience permissions problems with using Chrysalis with Linux to flash a keyboard. Installing the udev rules can help. Chrysalis should offer to install them, but doesn’t always. There will hopefully be improvements to Chrysalis to detect the permissions problems and to offer to fix them. One set of udev rules that should work is at


Thank you so much! I also had an error trying to update the firmware under Ubuntu Linux 22.04, but I saved the rules file you linked under /etc/udev/rules.d/ , restarted the keyboard and everything worked!

Thanks, @argonblue.

That does seem to have fixed things for me too.