Special symbols for Portuguese - Please help?

Having just received my board, I’ve been trying to configure some keys to display Portuguese special symbols, such as ´ ç and ˆ, but I cannot find them anywhere in the Chrysalis configuration tool. I’ve never had a problem using them in any keyboard whatsoever, but I don’t know what to do here. Could it be that these symbols cannot be displayed through the keyboardio? I am uploading a picture with a Portuguese layout keyboard that shows the symbols I am referring too.

I don’t know about Chrysalis but inside .ino firmware files you can define new keys that should make it possible if your OS keyboard layout is set to one which has those keys. I had to do that for some german characters. Though I’m thinking about switching to us international.

Here is a abnt2 layout file for QMK that you could port to Kaleidoscope: https://github.com/qmk/qmk_firmware/blob/b624f32f944acdc59dcb130674c09090c5c404cb/quantum/keymap_extras/keymap_br_abnt2.h

Thank you for your help. I don’t really understand why this is so difficult. From a consumer point of view I should be able to use the configuration tool to input any symbol that a standard keyboard has (especially at this price point), yet I have not been able to do this so far. My knowledge about keyboards is limited to typing, and maybe my inability to program the keyboard is due to my lack of knowledge, but I was under the impression that I would be able to configure it easily through Chrysalis, which does not seem to do the case. These things should not be hard.

Would you tell me what “port” means and how to do it?

Chrysalis is still under heavy development, maybe the feature is located in a non obvious place at the moment (but I have never used Chrysalis so I wouldn’t know). Should you have a github account maybe you could raise an issue in the Chrysalis repository: https://github.com/keyboardio/Chrysalis/issues

QMK and Kaleidoscope (the Firmware of the Model 01) have different naming conventions for keys, porting would mean you would have to adjust the names so they fit for Kaleidoscope. But if you have never programmed it may be daunting. you would have to follow this guide https://github.com/keyboardio/Kaleidoscope/wiki/Keyboardio-Model-01-Introduction to flash new firmware with your custom keys.

I would guess you can use the same key combinations inside Chrysalis that are used in the QMK file I linked. So to get ^ you would need to use shift together with ´`

I can try that for you when I get back home.

I suspect the problem is that Chrysalis assumes US-ASCII. To type non-ASCII characters such as dead keys and ç you will have to use a non-US keyboard setting in your OS.

Unfortunately, that means you will need to configure Chrysalis semi-blind because its key symbols won’t look like yours. Ç will look like " ; " in the software and the dead keys will be " [ " and " ’ " - but once you have it modified it should work once you select Brazilian Portugese in the OS.

If you are willing to get your hands dirty, I have a layout called “class4” that supports Brazilian Portugese (almost) out of the box in my fork here: https://github.com/andrewgdotcom/Model01-Firmware/blob/master/README-international.md

You will need to download the arduino development kit and follow the instructions to build and reflash your keyboard, so it’s far from “consumer-grade” but it should work. Note that you will have to edit the keymaps.h file slightly to change it from the default “class1” to “class4”, and to enable “modifiers-altgr”. If you then set Brazilian Portugese in your OS the square brackets should be on the keys to the left of Q and A, and the other keys should be close to their default locations ( ` - = will be on LED, Any and / respectively). It doesn’t support the Brazilian /? key because there simply aren’t enough physical keys on the keyboardio, but altgr-Q and altgr-W should work.

Let me know how you get on. :slight_smile:

Black Monday,

I am so ignorant of programming that much of what you say is comparable to trying to read Homer in Greek. I would welcome any help you can offer. And let me thank you in advance.

Just tried it inside Chrysalis and it works the same as in the .ino file (just like @andrewg described).

After setting my keyboard to setxkbmap -model abnt2 -layout br -variant abnt2 -option deadkeys I placed the following three keys in Chrysalis (you need to click the picture to see them, excuse the colour it’s from f.lux).

When I hit those keys they produce ç, ~ and `. So in order for you to get the keys you want you need to place the us-qwerty characters on your Chrysalis keymap. Below is a comparison picture which you can use (top is abnt2 and bottom is us-qwerty).

So to get Ç you need to put ; at the keyposition where you want to have it.

Thanks, Andrew.
I will definitely look into what you wrote and see what happens. I will update the topic once I have tried.

P.S. The problem has been solved. Thank you very much for your help.

BlackMonday, thank you so much for the instructions–I am now able to type the following characters:

ç ˜ ˆ ´`

I am in your debt.