Starting over and Still low memory available (Solved)

So I got everything setup fine, all my keys were working on my Mac. I figured out how to add the plugin Qukeys and made some changes to the keymap. I got a low memory available notice after compiling and noticed not all key presses were being sent.

So I reflashed back to the standard Model-01 Firmware but I still get the low memory available when I compile it and many of the keys wont get recognized. All the letter keys work but most things than are not letters/numbers aren’t working.

Is there a way to start over or reset the keyboard?


OK I tried the keyboard on my laptop and everything works perfectly. But when I put it back on the mac desktop that I programmed (flashed/arduino) it on it won’t recognize any keys that aren’t letters/numbers… anyone else see this?

Have you tried running Karabiner Event Viewer on the Mac to see what keypresses are getting that far? It sounds to me like this issue is probably something on the host, but I’m afraid I don’t have any specific ideas about what the problem could be.

Just tried it and on the left side the tilde, cmd and Fn aren’t registering anything

on the right Fn, space, comma, period, /, -, ;, ', =

but all work on he laptop. Strange but agree that something must be up with my desktop

@darrenph1 - Are you using USB Overdrive on the Desktop?

When I first plugged the keboardio in I had that problem but found the USB Overdrive thread and disabled it. During the day everything worked fine but then I had to restart a few times. After seeing your suggestion I went back and saw that USB Overdrive has something that starts at login so I disabled the USBOverdrivehelper from starting up during login and that did it. Thank you!

1 Like