Spacebar not working: USB Overdrive on macOS messes with the Model 01


(Caleb) #1

I’m a brand-new Model 01 user—keyboard arrived a few days ago. I’ve never done programming, but am tech-savvy enough to follow instructions using this Arduino software I just downloaded.

Out of the box, my Model 01’s spacebar key did not work. I type in Dvorak, but I tried it with my computer set to both Dvorak and QWERTY. Neither worked.

If I press the spacebar and then a letter key in rapid succession, I can sometimes get a space. Sometimes the spacebar seems to get stuck when I do that, inserting a long line of spaces until I hit another key.

How can I figure out if this is a hardware or software problem?


(Gergely Nagy) #2

I’d suggest giving the TestMode a try, and mail help@keyboard.io with the results.

(This sounds like a hardware issue to me)


(Caleb) #3

Thanks! I just did TestMode, and every key turned blue when I pressed it. Should I have expected the space key to do something different?

I’m going to email the Help people right now.


(Gergely Nagy) #4

I would have expected the space bar to turn red, but yeah, mail help@!


(Jesse) #5

[After some discussion offline, it sounds like the issue was that USB Overdrive was incorrectly messing with the Model 01]


(Tae) #6

I know this is not a solution but in case is useful to anyone I had problems with USB Overdrive too. As an alternative I started using SteerMouse and I can confirm it doesn’t mess with the Model 01 at all