Keys not working at all on a particular Mac OS system with USB Overdrive installed

After plugging in the keyboard as noted in MacOS - initial setup (keyboard setup assistant) that did not work, so I closed that assistant and just wanted to test out the keyboard. For the record I am trying this on a Mac Pro desktop running Mac OS X 10.11.6

I tried using the keyboard by typing into a basic text editor and found something shocking a handful of keys just don’t seem to do anything. Probably why the setup assistant failed that required key was not working on the right side.

Here is what I am observing on my Model 1 as keys that don’t seem to work:
page up
page down
;: works occasionally and sticks and repeats endlessly until I hit another key.
-_ |

Anyways I tried the keyboard on a Laptop running Windows 10 and all the keys are working just fine, with none of the above observed issues.

I re ran the keyboard setup assistant and selected ANSI layout too on the Mac, with no changes keys still above noted keys are not responding. Also checked and made sure the keyboard layout is set to correct US input type, and also make sure mouse keys and other accessibility features are off.

Tried the keyboard on a MacBook Pro running macOS 10.13.2, and have no issues with the keyboard, everything appears to be working as it should.

Tried this on another Mac a mac mini running OS X 10.11.6, and it is just working fine, so there is certainly something with just the Mac Pro that is causing the above mentioned keys not working.

Any Ideas what might be going on?

1 Like

Figure out what the issue was, I had installed USB Overdrive to enable programmable use of all five buttons on an old Kensington mouse.

I had also noticed that if I rebooted to older OS or even switched to a different user on the Mac Pro the keyboard starting working as expected.

As soon as I disable custom settings for any mouse any application in USB Overdrive, the Model 01 started working as expected.

Problem is that according to USB Overdrive the Model 01 is identified as 2 things both of which are of device type Mouse

For now not sure if its a bug in USB Overdrive or if its a bug in the KeyboardIO firmware, but anyways this was what was causing the keyboard to not function as expected.

The Model01 has two USB descriptors for pointing devices. It emulates both a relative mouse and an absolute mouse, so it’s not surprising that it would show up as two different devices there.

Yes but it seems there should be at least one keyboard too. What is this relative vs absolute mouse?

The Model01 emulates two kinds of mice: your regular mouse for the directional mouse keys and buttons (this is the relative mouse, because it reports to the host how much the cursor should move in either direction), and a touchscreen, for the warp keys (this is absolute mouse, because it reports absolute positions to the host, so it can move to a specific location, no matter where the cursor is).

The normal mouse and the keyboard appear on the same USB endpoint as a composite device. That may upset some operating systems or programs, though most of them support it just fine.

I just wanted to Thank you for this post. I use USB Overdrive a lot depending on what mouse I am using. This solved the problem for why certain keys weren’t working. I take it so far there is no way to be able to use Overdrive while using Keyboardio?

Your welcome, hopefully saved you some time. USB Overdrive should work, just make sure you don’t define and enable any rules that are applied to any mouse. Usually in the listing below you can see what kind of devices you have connected and then make specific rules for each.


1 Like

hi folks! i’ve found a slightly less disruptive way for USB Overdrive and the Model 01 to coexist: create a USB Overdrive config for “Model 01, Any Application”, and then disable only that profile:

to do so:

  • select the “Any Mouse, Any Application” profile
  • select “New Duplicate Settings”
  • set Mouse to “Model 01” and click OK
  • uncheck “Enabled” for this profile

this procedure immediately resolved exactly this same problem for me. hope it helps!

-steve (typed with my brand new Model 01 \o/)

1 Like