Water on Model 01

Spilled some water yesterday on my Model 01.

Saw that too late. I left it drying for some hours.

Yesterday — after ~ 3 hours — the return key was working again, but y, u, i not.

Should I give it more time (it has been less than 24h), should I try to repair (how), can I order a new board, or should I order the model 100 (but I probably cannot wait until January 2022, I think my RSI is going to hit me hard before that time).

Edit: All the leds are working now, but they aforementioned keys are not.

So, after 48h the “dead” keys are still dead. Is there anything fixable at this point?

I cannot think I can wait until Jan 2022, for the new one to come out :frowning:

I’d unscrew the circuit board and leave it out to dry for a couple more days. But if o is working and i is not, the repair *should be straight-forward It’d just be the connection between the row pin of i and o.

1 Like

Hi @jesse

It’s now open up like this, is this enough?

Yup! That oughta do it.

Hi @jesse,

Still no sign of life for the y , u , i and return.

The rest (numbers and leds) is working.

How should I perform the “repair” you mentioned?

It sounds like the broken electrical connection is between the two bits circled in red. Someone competent with a soldering iron might try just connecting those two pins.

1 Like

That’s really helpful, thank you! Is there a video on how I remove the keycaps to access what’s down there?

Oh, I’d recommend doing this from the back side of the circuit board. Just unscrew the circuit board from the plastic.

I had to drive the keyboard down to Italy during my holidays (1300km one-way), but the soldering iron FIXED IT!

Thanks so much for the patience — and the beautiful product!!

1 Like

How did the water damage the connection between those 2 pins to begin with? That he even had to use a soldering iron? I don’t get it, but I want to understand.

Well, how the connection was damaged with water, I don’t know. I know it was working well before spilling water on it (I mean, typing all day on the thing). By checking with the tester, we could see the connection was broken between the two letters.

We connected then the pins indicated by @jesse (picture above) from the back of the board, and voilà, everything works again. I’ve tested it for 5’ by clicking the keys, and the tester of course confirmed that electricity was flowing between all the keys involved.