When Pressing the { key I see unexpected [ output intermixed with {

When pressing the { key on the default function layer I am getting [ output, however the odd thing is that its not 100% wrong output. I get the proper output too, just have to press the key several times, and I will get the { I am expecting, after typing output as follows:

[[[{

Sometimes I need to press the key many times to get the right output.

This output happens in multiple text editors.

Any ideas what might be going on, have not modified this mapping to do anything like this.

Is your version of Kaleidoscope up to date? There have been problems with those keys in the past that have been fixed. I’m not claiming that there’s no bug there, but if you are running an old version, updating your firmware might fix the problem.

The problem seems to have resolved itself. I recently took the keyboard out of service for a few days, and since cleaning and reconnecting the problem has stopped, with no firmware changes.

Chrysalis version is 0.7.3+173

Firmware Version last flashed is 1.96

Figured out the problem, was not a problem with the keyboard other than it being really fast at pressing shift and remote desktop could not keep up with it. Which I did not even realize it was doing until I looked a little deeper using the keyboard viewer while trying to figure out the cause.

Eventually put it together that I was only having the issue while using a double hop with the first hop to VDI then from there another hop using Microsoft Remote Desktop. On that 2nd hop was where the problem was is occurring.

Its all in the Keyboard Settings, and where the Windows key combinations are applied:

On the remote computer --> You will see the the crazy output random output when pressing {

On this computer --> Fixes the issues, but you loose keyboard shortcuts on the remote system…

Screen Shot 2020-04-22 at 7.08.50 AM

Found the fix here https://superuser.com/questions/219461/shift-and-control-keys-out-of-sync-with-normal-keys-over-rdp

1 Like