Windows 7: Serial drivers for the Atreus

So I just got my Atreus, yay!

I’m having some trouble setting it up. I followed these directions but the Port menu item is greyed out :frowning:

Also I went to File -> Examples and under “Examples for Keyboardio Atreus” it lists Model01-Firmware. Is that what I want?

Please help!

Hi, can you tell us what OS you’re on, as well as which version of the Arduino IDE you’re using?

Thanks for the quick response. I’m on Win7 and Arduino 1.8.13

Ah. Windows 7 requires custom serial drivers to be installed for every device. And is also now officially unsupported by Microsoft.

You’ll need to use Zadig from https://zadig.akeo.ie/ to install the “USB Serial (CDC)” driver for the Atreus while the Atreus is connected.

1 Like

Just got my Atreus and Chrysalis will not recognize it :frowning:
I’m on Win 7 and Chrysalis-0.7.9+260

Thank you! Chrysalis now recognizes the Atreus and the Port menu allows me to select a port!

I went to File -> Examples and under “Examples for Keyboardio Atreus” it lists Model01-Firmware. Is that what I want? This doesn’t seem like the correct firmware since it includes LED stuff.

Is there a separate file for the Atreus firmware?

I am unable to flash the firmware with Chrysalis. I tried it with and without holding down the lower left key and I get this error:

atreus help

If you want to change the keyboard firmware, you will likely need to do some more work in Zadig to set up a driver for the Atreus in bootloader mode. (That -may- want to be libusb-win32 instead of CDC, but I’m not 100% sure on that.)

The example sketch you want is under Kaleidoscope -> Devices -> Keyboardio -> Atreus

1 Like

Thanks, I’ll play with it. Any idea whether I want Atreus (Composite Parent); Atreus (Interface 0); Atreus (Interface 2); or Atreus (Interface 3)?

I’ve tried all 4 listed drivers on Atreus (Interface 0) and Chrysalis only recognizes the Atreus with the USB Serial (CDC) driver. But it will not let me update the firmware and I sometimes get this error:

So, you don’t need to flash the firmware with Chrysalis - the factory firmware and the Chrysalis firmware are the same. (To update the Atreus’ layouts with Chrysalis, you don’t need to flash the keyboard, just edit the layouts and click Save)

If you -do- want to flash the firmware, you need to add another Zadig config:
What you need to do to get the “right” atreus for flashing mode in Zadig is to unplug it, hold down “Esc”, plug it in, and then it should show up as the Atreus Bootloader.

Held down Esc and installed libusb-win32 (v1.2.6.0) to Atreus Bootloader with Zadig.

I get the following error in Arduino:

avrdude: ser_open(): can't set com-state for "\\.\COM4"

An error occurred while uploading the sketch

I did hold down Esc when trying to install the firmware with Arduino.

I can change the keys in Chrysalis, but if I try to use Chrysalis to restore to factory defaults or update the firmware, I get that same error I showed above.

I also tried all the other drivers to Atreus Bootloader with Zadig but it does not work with them either.

These links may be helpful. In terms of arduino documentation - the Atreus works the same as an Arduino Leonardo or Arduino Micro.


1 Like

They don’t seem to provide much of a solution, as far as I can tell.

I made my layout in Chrysalis but that really limits the functionality since I can’t write hooks and things. Hoping there’s a way we can get this to work. :sob:

It can absolutely be made to work. I’m limited by…no longer having any hardware that can run Win 7.

You may need to go into Device Manager and remove the bootloader (1209:2302) version of the Atreus, then add it back with Zadig.
Trying to flash with verbose logging in the Arduino IDE is going to get us the best information.

You -may- also win by disconnecting the keyboard, holding down Esc, plugging it in, and -then- selecting the COM port in the Arduino IDE. Win 7 has a habit of changing the COM port out from under us in bootloader mode.

1 Like