Windows instructions to build firmware

Sorry to report I got the same error on a fresh Win 10 VM. I need to call it a day for today. I’ll try some new things tomorrow if I get a chance. Here’s hoping algernon can track it down.

Oh, that’s good to know. I’ve been using 1.6.x because that’s what the docs said to use. Will have to try something newer soon…

1 Like

I’m running Windows 10 and ran into the same issues as previously described following the procedure outlined by Javaru… The current selected board needs the core ‘arduino:arduino’ that is not installed…etc.

I’m basically a novice with Arduino, so take this for what it’s worth. I figured I’d tinker around with the software while I’m waiting for the hardware to arrive.

1 Like

I just tried to reproduce this on Windows 8.1, with the following steps:

  1. Downoladed Arduino 1.8.3 (.exe installer)
  2. cd \Documents\Arduino
  3. git clone --recursive hardware/keyboardio/avr
  4. git clone
  5. Started the Arduino IDE
  6. Selected Model01-firmware from the sketchbook.
  7. Set the board to keyboardio.
  8. Ran Compile & Verify.
  9. Observed no errors.

This all succeeded, and I wasn’t able to reproduce the issue. I installed Arduino with all bells and whistles, not sure if that matters.

I then uninstalled Arduino, and downoladed the zip file instead, extracted it to a random directory, and tried all the other steps - still succeeded in the end.

This is all very confusing to me :expressionless:

Any tips on what should be selected for the installation? Like I said, I’m a total novice… Perhaps I’m not selecting the right options?

@algernon - I followed your steps exactly, and now it seems to compile, though it throws this error/warning:

Invalid library found in C:\Users\ejinks4\Documents\Arduino\hardware\keyboardio\avr\libraries\Kaleidoscope-Plugin: C:\Users\ejinks4\Documents\Arduino\hardware\keyboardio\avr\libraries\Kaleidoscope-Plugin

Perhaps I was not putting the files in the right locations previously…

Can you see where Arduino.h is coming from?

Was discussing this with my husband, whose background is EE, and he thought that the installer might be doing something different based on what else is on the system - which would explain why it works for @jesse & @algernon but not for the rest of us.

This is a harmless warning, and an expected one too. It will be fixed soon-ish.

I just went with the defaults: default installation path, default components.

1 Like

Good deal. Thank you!

1 Like

@kajsa.anderson and others:

I found the issue!

Above, Jesse showed checking out the Arduino-Boards repo to hardware/avr/keyboardio, but in his follow up, algernon shows hardware/keyboardio/avr (Note the different nesting order of the avr and the keyboardio directories.)


  1. doing a fresh clone of theArduino-Boards repo with the hardware/keyboardio/avr directory structure
  2. restarting the Arudino IDE
  3. selecting the “Keyboardio Model 01” board in Tools > Board… (It had reverted to an generic arduino board)

…I no longer get the missing ‘arduino:arduino’ core error and was to able successfully run Verify/Compile. Simply renaming the directories so they are in the correct nesting order would likely work. I just did a fresh clone to have as “clean” a redo as possible when trying it.

I checked and the Model01-Firmware README does have the correct path. While I did RTFM, I did not pickup on the variance between it and what was posted above :frowning:

Hopefully, @kajsa.anderson, your issue is the same. :crossed_fingers:


Ack. I am SO sorry. Good catch.

1 Like

I can confirm that my issue was indeed the same.

1 Like

14 posts were split to a new topic: Windows 7: COM Port for Model 01 not showing up

I’m sorry! I’m writing the docs, but was in a car crash last week and have several months of rehab to look forward to. I hope to have docs up by the end of the weekend, but everything is slowed down for me right now.

I know a bunch of people have been successful with this, and I’m sure some folks will hop in with suggestions. Please keep asking questions and let us know what happens so we can help you and make the path a little smoother for the next folks.


Does anyone have a timeline on updating the wiki to include Windows specific instructions? I’m so out of my depth with this stuff I could use a guide. When I saw the code for the first time last night my reaction was to just go to bed and leave it for another time.

Edit: the title is “Windows Instructions to build firmware” but the discussion is all about this Win7 bug. The FAQ mentions: “Rather than taking an existing topic in a radically different direction, use Reply as a Linked Topic.” but for the life of me I can’t find this “Reply as a Link Topic” button. Can someone point me in the right direction?

I could take a stab at it, but I don’t have Model01 yet to test with. I’ve been able to get as far as creating a sketch that compiles, though.

1 Like

I’m really sorry about that. I think that ‘sometime this week’ is a reasonable guess at when I can write up a Windows install guide or re-edit my cross-platform install guide to include the Windows names for things.

1 Like

There are windows instructions up now, and have been since yesterday morning Pacific Time.

Read the Introduction,, then start here:


Thank you

Can’t wait to get started tomorrow :smile:

1 Like


Since I can’t figure out how to put a new admin post at the top of a thread, I’ve added a pointer to the new docs to @kajsa.anderson’s initial post.