Alt key combinations on Fn layer

When I want to use combos like Alt+F4 or Alt+Arrows I’m running into an issue - I have to press Alt first, so for instance this works fine:

Alt+Fn+4 (window closes)

but this doesn’t:

Fn+Alt+4 (nothing happens)

Other combos involving Fn work fine, so for instance Ctrl+Fn+4 and Fn+Ctrl+4 both do the same thing.

Jesse said in the Kickstarter comments that it’s odd, so I’m guessing it should work both ways.

I did some sanity checks like unplug the keyboard and try with another computer, but nothing changed.

Having to press Alt first is rather awkward for me, especially that my right thumb is a little less flexible than it should be. Can I make it work with pressing Fn first?

have you modified your keymap if you have can you link it? sounds like you have something on the alt key in the function layer.

I haven’t modified the keymap.

I’ve just tried to re-flash the default firmware using the instructions for Linux command line, but that ended with this error:

avrdude: ser_open(): can’t open device “/dev/ttyACM0”: Device or resource busy
avrdude: ser_open(): can’t open device “/dev/ttyACM0”: Device or resource busy
/home/rafal/Arduino/hardware/keyboardio/avr/build-tools/makefiles// recipe for target ‘flash’ failed
make: *** [flash] Error 1

The keyboard still works, but the issue persists. I’m not familiar with Arduino, should I try to google the error? I won’t brick the keyboard, right? Worst case scenario I’ll have to open the keyboard and reset it with an internal button, is that correct?

looks like something blocked the device from even being attempted to flash so you did nothing. I would double check the instructions especially about udev and the groups. Bricking the keyboard is pretty difficult from what I have read so don’t worry too much. There is a button inside the enclosure but you shouldn’t need it.

1 Like

Ok, that worked. I thought the instructions on this page were sufficient to re-flash the device as I got to this page directly from here, but apparently the udev and group setup is necessary too.

Thanks for your help. It’s odd that it didn’t work quite right on arrival, but everything’s as expected now.

Which Alt key are you using? The one on the thumb arc, or the other one? If you are using the other one, the explanation is simple: the Fn layer shadows the Right Alt key. When you press Alt+Fn+4, then when changing layers, the Alt key remains alt until it is held, because on layer change, keys already held will not suddenly change their function. So even if it is shadowed on the Fn layer, because it was pressed earlier, the shadowing doesn’t come into play. If you press Fn first, the key that used to be Alt on the base layer, becomes something else. The easiest here is to change the keymap so that the RightAlt key’s position on the Fn layer is made transparent.

Now, if you use the Alt on the thumb arc, that’s a different issue, because that one is not shadowed on the Fn layer, and should work.

Can you clarify which one you use?

Thanks for the details on shadowing, I’ll be definitely interested in that when I want to do some custom mapping. As for my current issue though, it’s resolved, see my previous comment.

1 Like