Num Lock Strangeness (on Win10)

Not sure if anyone else has encountered this or not but thought I’d post it. Having received my M01 a few days ago, I’ll been messing with it, remapped some keys, practiced some typing tests, etc.

OS - Win10
MOBO - asus x99 deluxe ii

Issue: numlock numbers don’t register, but some of the symbols do work, and OS reports opposite of what the numlock state is.

Steps to fix

reflashed firmware (, no change
reflashed to qwerty.deault, try numlock, no change
reflashed back to, no change

maybe a change in the bios will help? because when numlock is turned on, activated on the board, the OS thinks numlock is off. so I go into the bios and disable numlock on boot. Some interesting things happened.

first, I couldn’t get into the bios, needing F2 or delete to enter bios. both keys exist on the function layer. fn-2 and fn-bksp respectively. I suspect only the qwerty layer is accessible until the OS boots.

So I got a msft natural, plugged that in and entered the bios, disabled the numlock on boot.

After getting to the OS, numlock still doesn’t work when enabled on the M01. And the OS still thinks opposite of what the M01’s current state. So I toggle numlock on the msft natural, then toggle the M01. Now, the OS correctly displays numlock on when the M01’s numlock is activated AND the numbers on that layer work.

What happened? What am I doing wrong?

1 Like

Try changing your bios so that numlock is not enabled on boot.

Yep, tried that too.

Hm. I have seen some issues with numlock where if you hit it twice or three times quickly the os numlock ends up in the on state even though keyboard numlock is off. I suspect a race condition somewhere but I’m not sure whether to blame the keyboard or Linux. :smiley: It reverts to normal after the next push usually.

1 Like

This is a known issue that’s on my list, since only a couple of us had seen it wasn’t at the top of my list

From here on in, it’s trackable here:

Before I get cycles for it, I need to get Win7/Win8 programming fixed and really need to get some form of a backer update out :confused:

1 Like

What happened: We implemented numlock with a bug we’re having trouble tracking down
What are you doing wrong: Absolutely nothing. That’s a very useful bug report. I don’t think it’s related to your bios, though.

I did manage to get it to work. Although I’m fairly certain that if I were to reboot, I’d have the same issue. Thought for you - should add a bug category? Or would you prefer reporting issues to git?


No rush, my M01 works, I’ve read some of the issues with win7/8, better to get critical issues resolved first. And yes, this looks very much like a bug report even if I wasn’t consciously thinking it. haha.

I’d prefer that things that are actually bugs end up as GitHub issues, even if they start out with threads here asking for help.

1 Like