[Solved] Can't type danish character 'Å' in Chrome on MacOS


(lasse) #1

If you are using MacOS, could you test and see if you have the same problem. I’d like to know if it is a problem for me alone (related to keyboard hacks on my machine) or if it is a general bug in Chrome.

Test: In Chrome on MacOS, try typing option+shift+a and see if it gives you Å

On my macbook I can type danish characters using the classic:

  1. option ’ = æ
  2. option o = ø
  3. option a = å
  4. option shift ’ = Æ
  5. option shift o = Ø
  6. option shift a = Å

All six works in pages, Firefox and iTerm.
Only the first five works just fine in chrome.
So my problem is that I can’t type ‘Å’ in chrome.
My language settings is US and the keyboard is also US.


(Kris Kumler) #2

I am able to type Å on macOS (Mojave) in Chrome (70). I am using close to the original key layout for the firmware. I am also set to U.S. input source.

  1. Are you able to type Å in the Chrome page on the macbook keyboard?
  2. Are you able to type Å in Chrome, on a different site?
  3. Chrome also has language settings (under Settings -> Advanced), which may be worth checking out. Mine is currently set to English (United States) and English.

FWIW, Karabiner-Elements has an event viewer which can be handy to see better details of what is being sent.


(lasse) #3

Thank you very much for replying :smiley:

  1. As far as I can tell my problem is not keyboard specific, which is why I posted it in off-topic. It works is in all apps except for Chrome, no matter which keyboard I use.
  2. It doesn’t work in Chrome – no matter where I try it. I usually test it in the address bar
  3. My language settings is English (US), Danish, English

I have Karabiner installed (not Karabiner Elements - which is a fork??).
When I use the eventviewer I get the following output when I hit fn+shift+p, which in my layout maps to option+shift+a.

|eventType:FlagsChanged code:0x38 name:Shift_L flags:Shift misc:KeyCode::SHIFT_L| characters: |
|eventType:FlagsChanged code:0x3a name:Option_L flags:Shift Opt misc:KeyCode::OPTION_L| characters: |
|eventType:KeyDown code:0x0 name:A flags:Shift Opt misc:KeyCode::A| characters:Å |
|eventType:FlagsChanged code:0x3a name:Option_L flags:Shift misc:KeyCode::OPTION_L| characters: |
|eventType:KeyUp code:0x0 name:A flags:Shift misc:KeyCode::A| characters:A |
|eventType:FlagsChanged code:0x38 name:Shift_L flags: misc:KeyCode::SHIFT_L| characters:|

The output is similar to Æ/Ø which works - and also the letter works everywhere, except in Chrome.

It is really, really strange. But I suppose that it is good to know that it only happens on my machine. That should indicate that something is wrong with my Chrome installation…

I am on Version 70.0.3538.110 (Official Build) (64-bit) and Mojave, just like you.


(John T. Johnson) #4

Is option+shift+a a Chrome shortcut for something? Maybe it’s being stolen away for some function.


(Michael Richters) #5

I use option + shift + A in Chrome to toggle the Dark Reader extension for the domain of the current tab. Google doesn’t list that combo as a default shortcut for Chrome, but it’s possible an extension you’ve got is trapping that key combo.


(lasse) #6

Thank you all.

Yes, @merlin Dark Reader ate my Å !!

I didn’t think of that!