Esc key stopped working

I noticed while in VIM that my Esc stopped working today on my Model01. I looked up the Keyboardio community forums, and tried the hardware test mode. The Esc key remains red during the test mode.
Also tried turning keyboard upside down and pressing Esc key over 20 times.
What are my options?

1 Like

Next srep :

1 Like

I am happy to report that the problem was not hardware related.

On verifying with another keyboard and also with the native macbookpro keyboard, I continued to see the issue - the Esc key did not work.

On rebooting the Mac, the problem was resolved.

1 Like

I’ve noticed the same issue with my Atreus where the ESC key stops working on all keyboards for a while on my Mac. I’ve not figured out the pattern to it, but it is annoying.

Control+c is my workaround in vim.

Doing some web searches, it looks like people have been seeing this happen for a few months with Monterey. I haven’t found a solution other than a reboot, but it certainly seems to happen even to built-in MacBook keyboards. I don’t think it’s actually being caused by Kaleidoscope.

1 Like

I agree it seems to be an OS issue. I should have also mentioned that my previous searches turned up others with the same issue on macOS even when not using keyboards.