Model 100 firmware - Assigning LED color to keys does not work

I’ve been using my model 100 for quite some time now (I was one of the lucky ones who got an early release version) and I must say it’s the best keyboard I’ve ever used. I was able to modify the keyboard layout to my liking using Chrysalis except for one thing… No matter what I try, I cannot get my keyboard to show the LED color I want.

When I switch to layer 1, using the left palm key, all assigned keys light up red, even though I specified different colors to the keys using the “Color” option of the key using Chrysalis.

When I switch to layer 2, using the right palm key, no LEDs are lighted.

I know it’s not a technical issues as all LEDs light up when I assign a key to the LED control and use that to cycle through the various LED modes.

I’ve had this issue since I got the keyboard and I’ve tried several firmware versions. I’m currently running firmware version 0.90.1+42. I’ve also tried factory resetting.

Is this a problem with Chrysalis? Is there something I can do to fix this?

1 Like

It’s a problem of not enough documentation, and perhaps functionality overload. Try going into “Preferences / My Keyboard”, and set “default led mode” to 14.

The longer explanation is that there are multiple LED effects available in the default firmware for the Model 100, and only one can be active at a time (for various reasons I will not elaborate on just now). The colors assigned via Chrysalis are only active when the Colormap effect (the 14th led mode, not counting the 0th “leds off”) is active.

Thus, to see the colors you assigned, you need the Colormap effect active. The Numpad colors on layer 1 will still override those (another of those things we want to fix soon, but is surprisingly more difficult than it sounds), but otherwise your colors will be active.

We’ll be improving LED and color related in Chrysalis in the not too distant future.

3 Likes

I just updated my default LED mode to 14 and the LEDS are behaving differently (now some LED’s light up when I type), however, it still does not set the color I specified in Chrysalis.

Just tried setting a color to a button which previously did not have a color set to it.
That worked. However, setting a color to the one of the other buttons does not.

I may have miscounted then, I’m sorry (not enough coffee yet…). By your description, some buttons lighting up when you type, I’m probably 1 or 2 off, so try 15 or 16?

Tried 15 and 16 (and unplugged the keyboard to reset it after changing the value). No luck. With 14 at least some keys respond to the color setting. With 15 and 16 none.


Ah, Layer 1! That’s unfortunately going to be overridden by the numpad plugin at the moment. That’s something we’re going to address in the near future, but it overrides for now.

2 Likes

Thank you!

That worked. I copied everything from Layer #1 to Layer #3 and linked the button to open Layer #3.
The LED’s now show the correct color.

3 Likes

A ha! So if I want to add colors to Layer 1 (numpad) I should copy Layer 1 to Layer 3, and map the num key to lock to Layer 3?

(A little documentation would go a long way here, or at least a flag in Chrysalis that Layer 1 is a special sunflower so assigning colors in Chrysalis won’t do anything. It’s been confusing me since my Model 100 arrived.)

Correct!

…Yes. I’d love to do that but we keep running into more pressing issues to fix, so documenting this (or better yet, fixing it) is being pushed further back :frowning:

1 Like

Needs a community wiki really. Not that I’m volunteering!

We have a wiki :wink:

I think a Keyboardio wiki would be more useful than a Chrysalis wiki. Half the problem is the way information is in so many different forms & places. It’s really hard to form a coherent overview of how it all fits together.