Model 100 - triaging the "stuck key" issue

We’re continuing to try to track down the cause of the “stuck key” bug some folks rae seeing on the Model 100.

As far as I know, everyone seeing it is on Windows and has their keyboard connected through a USB hub that also has a monitor attached to it.

So far, we’ve been unable to reproduce the problem ourselves, which makes fixing it…more than a little bit difficult.

If you’re seeing this bug, could you please tell us:

  • hub brand and model (or if you see it with no hub involved)
  • OS and OS version
  • How often it happens and if there’s anything you can do to make it happen more often
  • If you’ve ever seen the problem with a Model 01, Atreus, or other keyboard
  • whether any LED animations freeze while the key is stuck (the “chase” effect would likely be the most visible)
  • whether another key press causes the key repeat (and LED freeze) to stop instantly

To add another datapoint I was seeing this all the time with a USB switcher on the Model 100 and also an Atreus running QMK.

I plugged the keyboard directly into the computer and have had no issues since.

What model of USB switcher is it?

ABLEWE USB 3.0, no idea what the controller is unfortunately.

I can say with some confidence it’s not the keyboard in this case. My Atreus has a whole bunch of hold/timing related mods and it works fine on a direct connection.

Through the switcher everything goes haywire, stuck keys, repeats, the works.

This thing? https://www.amazon.com/ABLEWE-USB-Switch/dp/B0BLVSGFG1

Understood. But there’s a decent chance that the switcher is doing the same thing that’s causing problems for others, just much worse. And that would be great for us if it helps us track down the issue.

1 Like

That’s the one I have

1 Like

Mine does that with this USB hub: Amazon.com
I’m on Windows 11, with all the latest updates. I can’t speak to the key presses or LED freezes, because I don’t have the hub to hand at the moment. I stopped using it because other USB devices plugged into it were also a little erratic, and what little I could find Googling around suggested that there’s an issue with USB-C having trouble having the bandwidth to handle certain display resolutions plus USB channels. So I switched everything back to direct connections to the laptop, and haven’t had the sticky keys since.

For what it’s worth, my work laptop also uses USB-C to dock the monitors, and my Kinesis keyboard there also had occasional “stuck key” glitches until I switched it to a direct connection instead of through that hub.

Good luck finding a fix, that would be nice, but I suspect the issue isn’t the keyboard.

Here is my situation.

I have a Philips 346B1C monitor which has a built in USB-C dock and KVM switch. The Model 100 is connected to the monitor.

I have a personal HP desktop running Windows 11 connected to the monitor through the USB UP port and Displayport. I have a work HP laptop also running Windows 11 connected by USB C to the monitor.

I only have one powered on at a time so I don’t manually switch things really at all. I rely on the auto switching.

I could be misremembering, but to the best of my recollection. I never have any problem with the laptop. With the desktop sometimes it is fine, sometimes it is wacky with repeating keys, etc.

If you want more info on version of windows or anything I can try or diagnostics to collect let me know.

I used to use a Model 01 with this same setup with no issues. That model 01 was running a very very old version of firmware. I believe the Model 100 is on the latest release version.

Hope this helps.

I’m experiencing this issue with this USB switch: Amazon Link

OS: Windows 10 Pro
Setup:

  • Fujitsu laptop with docking station
  • Model 100 and trackball plugged into USB switch
  • USB switch plugged into docking station
  • Two monitors plugged into docking station

The issue occurs most often, if not always, when the laptop goes into sleep or when the monitors turn off when Windows is locked.

I can stop the stuck key by pressing backspace. I don’t think I’ve tried anything else consciously, since backspace is what I have to press anyways.

Apart from the stuck key issue, I also see delayed input (pressing a key and it takes a second or more to show up on the screen) and completely ignored key presses, i. e. nothing shows up at all after pressing a key.

Unplugging and plugging in again resolves the issue.

I also have a Linux laptop without a docking station connected to the USB switch. As far as I can remember it hasn’t happened using this laptop.

@hunk - I’d love to know if this problem goes away if you turn off selective suspend:

https://support.displaylink.com/knowledgebase/articles/544228-how-to-fix-your-displaylink-product-from-repeatedl#8

I’ve also run into this problem from time to time with my Windows 11 system. For troubleshooting purposes I’ve disabled selective suspend per instructions above.

I share my Model 100 between a Mac and a Windows PC. I have the keyboard and mouse connected to brand new Anker powered USB hub (AK-68ANHUB-BV7A-0004) that is plugged into an old USB switch (Tek Republic TUS-200 USB Sharing Switch). I’ve not seen any particular pattern of steps that triggers the “stuck” key behavior but I’d estimate it happens once every week or two. Keyboard firmware is latest available within Chrysalis. Haven’t done anything crazy to my keyboard other than remap a few keys to help support my Colemak learning. Let me know if there is any additional info or troubleshooting steps you’d like me to take here.

Swinte, it looks like…this might be another case of a bug in the hub :confused:

almost the perfect solution i was looking for sounds a lot like what you’re seeing.

Thanks for your reply, Jesse. It is an definitely an old and ancient switch. That said, I never had this issue with my previous keyboard (Microsoft natural 4000) over past five years or so. Been meaning to replace it for awhile but haven’t found one that doesn’t have mixed reviews.

Understood. We’re continuing to push on it.

Hi @jesse, unfortunately I don’t have the selective suspend option in my advanced power settings. However, I’ve turned off the third option here in this screenshot. I’ll let you know if I notice any difference.
image