What to do if your keyboard seems to duplicate keystrokes or a key stops working

(Jesse) #1

We’ve had a handful of reports of Model 01s developing ‘key chatter’ over the first week or two of their lives. This usually manifests as repeated keystrokes. For example, if you type ‘r’, the keyboard might instead send ‘rr’ or ‘rrr’ some or all of the time.

This is definitely not the kind of experience we want you to have. We know it’s frustrating.

This is typically due to a bit of dust in a keyswitch and is something we’ve generally been able to help customers resolve in the field, without needing to send their keyboard to us for repair or replacement.

If you’re running into something that sounds like this issue, please email us at help@keyboard.io and we can walk you through the debugging process. You can rest assured that we’ll make things right for you, one way or another.

It’s important that you email us directly for two reasons:

First, we want to make sure nobody is suffering with a misbehaving keyboard.
Second, it’s important for us to keep a count of every time this issue comes up so we can provide accurate feedback to our suppliers.

We’re really sorry for any hassle this causes.

<3 j+k

Multiple characters coming from one keypress
Key repeating spuriously
Ghost keys or why is my keyboard broken
Minor annoyances with Model 1 under heavy use
Top 5 plugins or macros?
Duplicated key-presses, especially on the thumb keys (chatter)
Key malfunction on one key 't'
(米p) #2

I have founnd that my keyboard occasionnally generates a seconnd n when typing n. I have tried repeatedly pressing the n key, and haven’t yet nonticed any sort of pattern to the generation of double n’s. No other keys seem to be affected. This post itself is an example of the effect – I have not corrected the double letters. Interestingly, it appears that the second nn can appear after the followinng typed character. Has anybody else observed similar behaviour?

(Jesse) #3

That’s no good.

It sounds like you ended up with a keyboard that either has a defective keyswitch or a soldering issue on the switch or diode of your ‘n’ key.

Can you drop us email at support@keyboard.io so I can set up a replacement for you?

(Jennifer Leigh) #4

I get double A’s fairly frequently and occasional double S’s, but I attribute it to being slow enough getting my finger off the key to trigger a held key repeat. I’m planning on ferreting out the setting to make that delay longer.

Yours looks like a different issue to me, just noting my case for others with doubled letters. This timeout+personal style affects my OneShot modifiers as well.


Yours is the second report of the N key spitting out phantom/duplicate keystrokes. Weird. :thinking:

(Jesse) #6

Hi @depaula,

I’m so sorry your keyboard isn’t behaving correctly. We’ve had a couple reports of “key chatter”, which is the usual name for what you’re seeing. So far, we’ve been able to step folks through an easy at-home resolution.

Shoot us email at help@keyboard.io and we’ll get you sorted out. It shouldn’t require a keyboard replacement, but we’ll make this right, no matter what.


[As a note, I’m going to move this conversation into the forum thread with an earlier report of this issue, just for housekeeping purposes]

(depaula) #7

Today the ‘l’ key (which is the ‘n’ key with my flashed Dvorak mapping) has started to spit out duplicate characters. I’m into the second week of using the keyboard at work and it’s only now beginninng (there’s one there) to show up. NNN(againn!)ot sure what’s up.


Thannk you,

Running MacBook Pro with Touchbar / High Sierra

(Simon Lydell) #8

Today I noticed that my butterfly key doesn’t always register when pressed down.

I’ve had my keyboardio for over a week, but since the butterfly key is mapped to Right Alt, which I never use, I haven’t noticed anything unusual about the key until now. Today I remapped the key, and was confused why nothing happened when I pressed the key. At first I thought I had made a mistake in the firmware, but it turned out that the key simply doesn’t always register.

I’ve found the LED Stalker effect to be very helpful when “debugging” this. The butterfly key doesn’t always light up when I tap it. On the other hand, the Esc key on the other half of the keyboard always lights up.

It seems like it matters where on the key I put my fingertip when pressing the key.

  • At the lowest corner, closest to the H key, it feels like 9 times out of 10 the key does not register.
  • At the opposite, highest corner, closest to the Alt thumb key, it feels like only 1 time out of 10 the key does not register.
  • Between those points there’s kind of a spectrum of how well it registers.

It also feels like if I mess around with the key for a while, pressing it very hard, holding it, slightly rotating my finger, wobbling it, etc. it gets better for a while even when tapping it “normally.”

This absolutely not a deal breaker or anything for me. Mostly wanted to share the experience and give a tip on something that potentially could be improved in the production in the future :slight_smile:

  • Has anyone else noticed anything like this?
  • Is there anything I can do? I’ve thought of taking the keycap off and checking the switch, but I don’t have a keycap puller, so I haven’t gotten around doing it yet.

(Mark Vedder) #9

There have been a few reports of problematic keys. I recommend you take a look at this topic, specifically Jesse’s comments, for some guidance: What to do if your keyboard seems to duplicate keystrokes or a key stops working

(Jesse) #10

Indeed, shoot us email at help@keyboard.io and we can help get it taken care of, one way or another.


(Simon Lydell) #11

So, in case somebody else stumbles upon this thread, one of the things mentioned via email was “to turn your keyboard upside down and to press the offending key 10-20 times. Most of the time, that will resolve the issue.”

I did that, and so far that seems to have completely fixed the issue! :smile:

(Jesse) #12

It’s sill really important to contact help@keyboard.io if you run into something like this. We need to keep track of who sees this and how often, otherwise we can’t push on our suppliers to improve things.

(Simon Lydell) #13

Yes, I did contact that email address, it just wasn’t super clear from my comment :slight_smile:

(Jesse) #14

Yep! I just wanted to make sure that anyone who saw your note here knew they really ought to email us :slight_smile:

(Jesse) #15

ADMIIN: I’m going to merge this content into the other thread about chatter.

(Dan Miller) #16

Today somehow my Model01 keyboard started inserting multiple space characters when I press space. Not every time, but some times. Sometimes it’s one extra space sometimes it’s multiple extra spaces.

I’ve left the spaces in this post to illustrate the problem. :grin:

I’ve tried unplugging the keyboard and plugging it back in as well as restarting my Mac. I verified that the keyboard on the laptop itself does not exhibit this problem.

Anyone know how to fix this? Is there a way to reset the keyboard to factory defaults? Thanks!

(Dan Miller) #17

Here’s a video illustrating the problem. I used keycastr to show the keys that are being pressed on the bottom. At the end of the video I’m just pressing “a” “” “a” “” repeatedly, but at a regular cadence.

(Gergely Nagy) #18

This sounds like the key chatter issue mentioned here:

Please follow the advice given there!

(Jesse) #19

[Dan wrote to us. I’m merging this into the master thread]

(pnunn) #20

Hi guys,

I’m loving the model 01 in general but am having a few nigglie issues with it on my mac.

I often get multiple key presses recorded (P and bksp seem to be the worst contenders) which may be related to me not releasing the key quickly enough but it happens frequently enough to be a real pain (especially as my password has a P in it which often fails and I think its because of the double character injection).

I must admit I havn’t flashed the firmware for quite a wile (because I’ve swapped the tab ~ and esc keys in my layout and am not sure how to re-flash without loosing that change) so there may be some improvements I’m missing.

Any thoughts.?